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Introduction
Welcome to Bricklayer, the fast-paced falling blocks game!
The rules of Bricklayer are simple.    Oddly-shaped blocks appear at the top of
the pit and drop toward the bottom.    When a block reaches the bottom, it 
stops moving and a new block appears at the top.    When blocks are 
dropping, they may be rotated or moved left or right.    By manipulating 
blocks as they fall, you can control the place and orientation in which they 
land.    The object of the game is to drop blocks so that they completely fill 
horizontal rows of the pit.    When a horizontal row is completely filled with no
gaps, it will disappear and the blocks in the rows above will drop down to 
take their place.    The game ends when the pit is entirely filled with blocks, 
so the more rows you clear, the more pieces you'll have room for, and the 
longer you'll be able to play.

System Requirements
Bricklayer has been beta tested on i386, i486, and Pentium systems with 4-
8MB of memory.    The memory requirements may be quite steep because 
Bricklayer needs to load close to 1MB of music files.    To enjoy the 
background music and sound effects, you will need to have a sound card 
with wave playing ability supported by Windows (such as Microsoft Sound 
System, or Creative Labs Sound Blaster).

See troubleshooting for advice with common problems.
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Scoring
You receive points for dropping
pieces, and for clearing rows.

The number of points you receive for clearing a row increases if you clear 
more rows at once.    The first row eliminated by dropping a block is worth 
100 points.    If dropping the block eliminates two rows, you receive 100 for 
the first row and 200 for the second, for a total of 300 points.    The third row 
is worth 300 points, and the fourth 400, so if you eliminate four rows with the
placement of a single block, you are awarded 1000 (100+200+300+400) 
points.    This makes eliminating two or more rows simultaneously more 
advantageous than eliminating them one at a time.    You also receive 1 point
for each row that a block falls when you drop it.    In addition, there are ways 
of scoring large bonuses by making special plays, but you'll have to discover 
them for yourself!
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How to Play A Game
To quickly get started, select Begin Game from the File menu, or just use the 
key sequence Control-B.    If you are just starting out, you will begin playing 
on Level 1.    Use the J, K, and L keys to move the falling block left, rotate it, 
or move it right, respectively.    To drop the block, press the SPACE key.    You 
can change the key bindings for these actions by selecting the Change Keys 
option from the Options menu.
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Registering
Bricklayer is $10 shareware 
and free for those people 
who've paid for previous 
versions.

If you enjoy and play Bricklayer, please send in the $10 shareware 
fee.
It is not very much compared to the cost of a commercial game, and it 
motivates me to keep improving Bricklayer as well as to work on new games. 
If you play, please pay.    Upgrades to new versions of Bricklayer are always 
free for registered users.    Those who register will also be kept informed of 
new version releases, as well as the releases of any new products.

To register Bricklayer, please send a US$10 check payable to Yevgeny 
Gurevich to the address listed below.    If you live outside of the U.S., please 
send an international money order (preferred) or cash, since checks drawn 
on foreign banks are sometimes difficult to clear.

Site licenses are available - please contact me for more details.

post: Yevgeny Gurevich
129 Franklin Street #112
Cambridge, MA 02139
U.S.A.

Email: yevg@aol.com

Once you have registered, you will receive a registration code.    Select the 
Register menu item from the Help menu and enter your name and 
registration code as they appear on the registration information returned to 
you.    This code will remove any notices to register the product, clearly 
identify your copy as registered to your or your organization, and allow you 
to access some custom features of Bricklayer.
For fast response, request to have the code mailed to you electronically.
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Recording Events
One of the advanced features of 
Bricklayer is its ability to record, 
save, and playback your games.

To record a game, first select the Event menu and select the Record menu 
item.    The Record item will now have a check mark next to it, alerting you to
the fact that the next game to be played will be recorded into the Event 
Buffer.

You can then begin playing a game of Bricklayer as explained in How to Play 
a Game.
When you are done with the game, you can save it, by using the Save 
Events... menu item from the File menu, or play it back from the Event Buffer
by selecting Replay from the Event Recording menu.

You can only save one game at a time in the Event Buffer.    If the Record 
menu item is selected from the Event Recording menu and you play two 
games in succession, only the last will be in the buffer.    You may load and 
replay as many games as you wish.

Related Topics:
None



AutoPlay
The AutoPlay feature lets the computer play a game of Bricklayer.    The 
computer plays at two levels of intelligence - Quick n Dirty and Deep 
Thought.

The fast player thinks quickly but is not as good at playing the game as the 
slower and smarter player, which uses the Next Piece for lookahead.    On fast
systems like i486DX2-66's, the smart player is faster than the dumb player 
on an i486SX-33.

For programmers:
I may release a programming interface and guidelines to allow 
you to write your own Bricklayer players in the form of DLLs.
Please write me if you are interested.
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Whats new in version 1.6 ?
Version 1.6 of Bricklayer fixes 
a few bugs and introduces 
some features for registered 
users.

· This version of Bricklayer has support for external piece and background 
graphics modules.    The Preferences dialog box allows the user to select 
alternative background graphics and piece-graphics modules.    Currently, 
alternative modules are available on a separate goodies disk which may 
be purchased for a nominal fee by registered users.    A few alternate 
graphics files are included in the shareware distribution.    Some of these 
may only be used by registered users of Bricklayer.

· Registered users are acknowledged with a small notice in between games.

· The gameboard size can be doubled for users with large monitors or high 
resolutions.

· An incompatibility with PC Tools Desktop™ has been fixed.

· Continuous background music is more stable.

Related Topics:
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Changing Background Graphics
Background graphics are bitmaps which are tiled in the main game window, 
usually different for each level in the game.    You may select alternate 
graphics modules in the Preferences dialog box.

Once a new module is selected, it is loaded instantly and loads by default the
next time that Bricklayer is executed.

The easiest way to select alternate graphics modules is to click on the 
Browse button in the Preferences dialog box and double click on 
available .BLB files.    If the File-Open dialog box does not show the drive 
where Bricklayer is installed, you will need to change to the directory to one 
where the alternate graphics modules are installed.

Related Topics:
Changing Piece Graphics



Changing Piece Graphics
Piece graphics are the little bitmaps which are drawn to represent each of 
the seven colored pieces in Bricklayer.

Once a new module is selected, it is loaded instantly, and loads by default 
the next time that Bricklayer is executed.

The easiest way to select alternate graphics modules is to click on the 
Browse button in the Preferences dialog box and double click on 
available .BLP files.    If the File-Open dialog box does not show the drive 
where Bricklayer is installed, you will need to change to the directory where 
the alternate pieces modules are installed.

Related Topics:
Changing Background Graphics



Music and Sound    
Bricklayer contains terrific sound effects
and background music.    Through the 
Options menu, you can elect to hear 
just the background music, just sound 
effects, or both.

Sound effects and background music can be individually toggled using the 
Music and Sound Effects menu items in the Options menu.    A check mark 
next to each of the items means that it is active for the current and all 
following games.

Control over whether background music and sound effects are loaded each 
time Bricklayer is executed is handled by the Load Music check box in the 
Preferences dialog box.    For users who do not have wave-output sound 
support, the Load Music option can be deselected (no check mark).    This will
prevent Bricklayer from loading the background music and speed the total 
load time.    All sound and music options will be disabled for future loads as 
well.    This option may be checked off to enable loading music at any time.

Wave Mixing
This version of Bricklayer, 1.60, uses the Microsoft WAVEMIX.DLL sound 
mixing library.    You may notice that the background music has stopped 
playing after six or seven minutes (and in some instances, even less) of 
continuous music when both music and sound effects are enabled.    If this 
occurs, press the [TAB] key to restart the music.

The music WAV files are Copyright Opinicus Microtechnologies, and may be 
freely distributed only as part of the Bricklayer for Windows game for use by 
the Bricklayer executable.    See the distribution information for more details.

Related Topics:
None



Controls
The default controls for Bricklayer are:

j Move Left
k Rotate
l Move Right
SPACE Drop
a Push Down

The numeric keypad keys are always active as control keys in addition to any
user-selectable settings.    On the numeric keypad, the 4, 5, 6, and 0 act the 
same as the j, k, l, and space.

Keyboard control is customizable with the Change Keys item in the Options 
menu.    When you select Change Keys a dialog box prompts you to change 
any or all of the keys which control piece movement.    If you select CANCEL, 
none of the changes come into effect.    Selecting OK in the menu changes 
key bindings to your newly-selected keys.    These keys are saved in the 
Bricklayer preferences file and are active in the current game of Bricklayer, 
and all future games as well.

Related Topics:
How To Play A Game
Scoring



Comments, Suggestions, Bug Reports
I look forward to hearing from you.    If you encounter problems while playing 
Bricklayer, I would appreciate any information that you can provide, such as 
your system configuration and a detailed description of the problem.    
Suggestions for improvements are also welcome.

Send email to
yevg@aol.com



Bricklayer Preferences
Bricklayer has many options which you can set to customize the game to fit 
your taste.    Select Preferences from the Options menu.    A preferences 
dialog box appears with check boxes to toggle system settings, and Browse 
buttons to select alternate graphics files.

Fast Left/Right 
Motion

If this option is on, holding down the move left or 
right key continuously will move pieces faster.

Pause on Lose 
Focus

If this option is on, the game automatically pauses 
when you switch from Bricklayer to another 
program or window.    With this option off, the game 
continues even if you move on to another program. 
Unselecting this option is useful if you want to see 
the computer play in the background.    The music 
will not play once you switch from Bricklayer so as 
not to hog the sound resources.

Force 16-Color 
Mode

On some 16-color-only systems may speed up the 
game.

Load Music on 
startup

By default this option is on and tells Bricklayer to 
load music files each time the program is loaded.    
Setting this option off will prevent music from being
loaded, speeding load time but preventing you from
listening to the background music.

Double-Size Blocks Doubles the size of the blocks and the gameboard 
for systems with high-resolution displays.    Nice for 
kids, too.

The input box allows you to enter how many levels of debris are placed on 
the screen at the start of each game.    You can challenge yourself of the 
computer by increasing the debris.

The Background Graphics and Piece Graphics browse buttons allow you to 
select alternate graphics.    Just click on the appropriate browse button to get 
a listing of available files.
Related Topics:
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Common Problems and Solutions
Due to rather steep memory and processor requirements, some users may 
experience problems starting, or playing with Bricklayer.    This section details
some common problems and their solutions:

Bricklayer won't start
up

Often due to insufficient memory or incompatibilities 
with sound hardware.
Try creating a file called BRICKLYR.INI in your 
WINDOWS directory and putting the following lines 
there:

[Settings]
LoadMusic=0

This will force Bricklayer to ignore the music and sound 
settings and not load any music files.    You will be able 
to play, but will have no music or sound effects.

Another problem may be a video-driver incompatibility.   
Try running Bricklayer with the -d command-line option.

Background music 
stops playing during 
the game

Some problems involved with mixing the sound effects 
and background music result in the background 
music sometimes stopping after a few minutes of 
playing.    You have several options.

· If you select to have music but no sound effects, this 
problem does not seem to occur.

· You may press the TAB key to restart the music during
play.

Game seems 
extremely slow

On some slower computers, the processing needed to 
play the background music and sound effects becomes 
the major time sink.
Try unchecking the music and/or sound options.    
Without background music, the game will feel snappier 
on slower computers.

Audible clicks when 
pieces drop

The sound mixing is done in software and is not perfect.  
Some audible clicks may be heard when pieces drop and
background music is on.    This is especially evident 
when using AutoPlay.
If you like the background music, getting rid of the 
sound effects by unselecting them from the options 
menu will make the music sound much smoother.    If 
you value the sound effects more, try unselecting the 
music option.    The clicks will be less evident.



Finally, you may try modifying the settings in the 
WAVEMIX.INI file.    This file controls options in the 
wavemixing library which are not tuned by Bricklayer 
itself.    Try changing the number of ping-pong buffers or 
the buffer length.




